Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
Sample Output
NO YES
题意:给你n个电话号码,判断是否存在一个电话号码是另一个号码的前缀,如果存在则输出no,否则输出yes
#include<stdio.h>
#include<string.h>
#include <iostream>
#include <string>
#include <algorithm>
using namespace std;
int ct;
struct TireNode
{
int count;
struct TireNode *branch[10];
TireNode()
{
count = 0;
for (int i = 0; i < 10; i++)
branch[i] = NULL;
}
}NodeNum[100000];//静态数组储存Tire树结点!
//Tire树的插入操作!
void TireInsert(TireNode *&root, string str)
{
int i, len;
len = str.length();
TireNode *p = root;
for (i = 0; i < len; i++){
if (!p->branch[str[i]-'0']){
p->branch[str[i]-'0'] = &NodeNum[ct];
ct++;
}
p = p->branch[str[i]-'0'];
p->count++;
}
return ;
}
//Tire树的查询操作!
bool TireSearch(TireNode *root, string str)
{
if (root == NULL)
return 0;
int i, len;
len = str.length();
TireNode *p = root;
for (i = 0; i < len; i++){
p = p->branch[str[i]-'0'];
if (p->count == 1)
return 1;
}
return 0;
}
int main()
{
int tc, i, n;
string phone[10010];
bool flag;
cin >> tc;
while (tc--){
cin >> n;
flag = true;
memset(NodeNum, NULL, sizeof(NodeNum));
TireNode *root = &NodeNum[0];
ct = 1;
for (i = 0; i < n; i++){
cin >> phone[i];
TireInsert(root, phone[i]);
}
sort(phone, phone+n);
for (i = 0; i < n; i++){
if (!TireSearch(root, phone[i])){
flag = false;
break;
}
}
if (flag)
cout << "YES" << endl;
else
cout << "NO" << endl;
}
system("pause");
}
原创文章,作者:kepupublish,如若转载,请注明出处:https://blog.ytso.com/140409.html